Skip to content

← Public intelligence

npm package

@rocket.chat/livechat

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Cross-site Scripting in @rocket.chat/livechat

    CVE-2022-21830 · GHSA-hf55-c445-2w97

    Affected
    • npm @rocket.chat/livechat < 1.9.0
    Fixed in
    1.9.0· Vendor fix available
    Issue
    A blind self XSS vulnerability exists in RocketChat LiveChat versions lower than 1.9 that could allow an attacker to trick a victim pasting malicious code in their chat instance.

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →