Critical, CVSS 9.8npmAmendedPublished
Code injection in @rkesters/gnuplot
CVE-2021-29369 · GHSA-f2jw-pr2c-9x96
- Affected
- npm @rkesters/gnuplot < 0.1.1
- Fixed in
- 0.1.1· Vendor fix available
- Issue
- @rkesters/gnuplot is an easy to use node module to draw charts using gnuplot and ps2pdf. The gnuplot package prior to version 0.1.0 for Node.js allows code execution via shell metacharacters in Gnuplot commands.
Recommended action: Upgrade to 0.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.