Skip to content

← Public intelligence

npm package

@payloadcms/plugin-stripe

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.4npmAmendedPublished

    Payload: Insufficient Access Control in Stripe REST Proxy

    CVE-2026-105848 · GHSA-r9v2-gg2j-22q5

    Affected
    • npm @payloadcms/plugin-stripe < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34
    Fixed in
    4.0.0-canary.343.90.0· Vendor fix available
    Issue
    Impact An authenticated user could perform unintended Stripe operations through the optional Stripe REST proxy. You are affected if ALL of these are true: - Your application uses @payloadcms/plugin-stripe. - The optional Stripe REST proxy is enabled. - An authenticated user can reach the proxy. Deployments that do not enable the Stripe REST proxy are not affected. Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds Upgrading to a patched version is recommended. If you cannot upgrade immediately, disable the Stripe REST proxy. If it must remain enabled, restrict access to trusted users and only the required Stripe operations.

    Recommended action: Upgrade to 4.0.0-canary.34 (pre-release) or 3.90.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →