Critical, CVSS 9.3npmAmendedPublished
Payload: Prototype pollution in Payload Import Export plugin
CVE-2026-105844 · GHSA-qf28-8hc6-vwrp
- Affected
- npm @payloadcms/plugin-import-export >= 3.0.0, < 3.88.0; >= 4.0.0-canary.0, < 4.0.0-canary.27
- Fixed in
- 3.88.04.0.0-canary.27· Vendor fix available
- Issue
- Impact An unauthenticated user could cause unintended application behavior when the Import Export plugin is enabled, allowing an attacker to submit and execute remote code (RCE). Applications that do not use @payloadcms/plugin-import-export are not affected. Patches Users should upgrade Payload packages to = 3.88.0 or = 4.0.0-canary.27. Workarounds Upgrading is recommended. Until then, disable the Import Export plugin or restrict access to its endpoints.
Recommended action: Upgrade to 4.0.0-canary.27 (pre-release) or 3.88.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.