Critical, CVSS 10.0npmAmendedPublished
Payload Form Builder has an RCE issue
CVE-2026-105857 · GHSA-r488-j9vj-wx3q
- Affected
- npm @payloadcms/plugin-form-builder < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34
- Fixed in
- 4.0.0-canary.343.90.0· Vendor fix available
- Issue
- Impact A vulnerability in @payloadcms/plugin-form-builder in versions < 3.90.0 allow submissions which could be crafted to execute remote code on the server. You are affected if: - You are using @payloadcms/plugin-form-builder Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34.
Recommended action: Upgrade to 4.0.0-canary.34 (pre-release) or 3.90.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.