Skip to content

← Public intelligence

npm package

@payloadcms/plugin-ecommerce

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    Payload Ecommerce has an order confirmation validation issue

    CVE-2026-105850 · GHSA-8r29-2mp2-pmrw

    Affected
    • npm @payloadcms/plugin-ecommerce < 3.90.0; >= 4.0.0-canary.0, < 4.0.0-canary.34
    Fixed in
    4.0.0-canary.343.90.0· Vendor fix available
    Issue
    Impact When using the Stripe payment adapter, an order confirmation could be processed more than once under certain conditions. You are affected if: - You use @payloadcms/plugin-ecommerce with the Stripe payment adapter. Deployments that do not use the Stripe payment flow are not affected. Patches Users should upgrade Payload packages to = 3.90.0 or = 4.0.0-canary.34. Workarounds Ensure Stripe order confirmations can only be processed once. This is a temporary mitigation; upgrading to a patched version is recommended.

    Recommended action: Upgrade to 4.0.0-canary.34 (pre-release) or 3.90.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →