Skip to content

← Public intelligence

npm package

@opentelemetry/instrumentation

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1npmAmendedPublished

    Unsanitized user controlled input in module generation

    GHSA-f8pq-3926-8gx5

    Affected
    • npm @opentelemetry/instrumentation >= 0.40.0, < 0.41.2
    Fixed in
    0.41.2· Vendor fix available
    Issue
    Impact The import-in-the-middle loader used by @opentelemetry/instrumentation works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an import() function. Patches This vulnerability has been patched in @opentelemetry/instrumentation version 0.41.2 Workarounds - Do not pass any user-supplied input to import(). Instead, verify it against a set of allowed values. - If using @opentelemetry/instrumentation with support for EcmaScript Modules is not needed, ensure that none of the following options are set (either via command-line or the NODEOPTIONS environment variable): References - https://github.com/DataDog/import-in-the-middle/security/advisories/GHSA-5r27-rw8r-7967

    Recommended action: Upgrade to 0.41.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →