High, CVSS 7.0npmAmendedPublished
ejson shell parser in MongoDB Compass maybe bypassed
CVE-2024-6376 · GHSA-jxr4-4prv-mh83
- Affected
- npm @mongodb-js/connection-form < 1.20.1
- Fixed in
- 1.20.1· Vendor fix available
- Issue
- MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connection handling. This issue affects MongoDB Compass versions prior to version 1.42.2.
Recommended action: Upgrade to 1.20.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.