Skip to content

← Public intelligence

npm package

@modelcontextprotocol/inspector

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6npmAmendedPublished

    MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server

    CVE-2025-58444 · GHSA-g9hg-qhmf-q45m

    Affected
    • npm @modelcontextprotocol/inspector < 0.16.6
    Fixed in
    0.16.6· Vendor fix available
    Issue
    An XSS flaw exists in the MCP Inspector local development tool when it renders a redirect URL returned by a remote MCP server. If the Inspector connects to an untrusted server, a crafted redirect can inject script into the Inspector context and, via the built-in proxy, be leveraged to trigger arbitrary command execution on the developer machine. Version 0.16.6 hardens URL handling/validation and prevents script execution. Thank you to the following researchers for their reports and contributions: Raymond (Veria Labs) Gavin Zhong, <superboyzjc@gmail.com & Shuyang Wang, <swang@obsidiansecurity.com.

    Recommended action: Upgrade to 0.16.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.4npmAmendedPublished

    MCP Inspector proxy server lacks authentication between the Inspector client and proxy

    CVE-2025-49596 · GHSA-7f8r-222p-6f5g

    Affected
    • npm @modelcontextprotocol/inspector < 0.14.1
    Fixed in
    0.14.1· Vendor fix available
    Issue
    Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities. Credit: Rémy Marot <bughunters@tenable.com

    Recommended action: Upgrade to 0.14.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →