Skip to content

← Public intelligence

npm package

@koa/router

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.5npmAmendedPublished

    @koa/router has an Access Control Bypass

    CVE-2026-9495 · GHSA-47p6-69vm-vw6v

    Affected
    • npm @koa/router >= 14.0.0, < 15.0.0
    Fixed in
    15.0.0· Vendor fix available
    Issue
    Versions of the package @koa/router from 14.0.0 and before 15.0.0 are vulnerable to Access Control Bypass due to the middleware being silently dropped from the execution chain when the router prefix contains path parameters. Depending on what the skipped middleware was supposed to protect, an attacker could bypass authentication and authorization, evade rate limiting or bypass input sanitization.

    Recommended action: Upgrade to 15.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →