Skip to content

← Public intelligence

npm package

@kindspells/astro-shield

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7npmAmendedPublished

    In Astro-Shield, setting a correct integrity attribute to injected code allows to bypass the allow-lists

    CVE-2024-30250 · GHSA-c4gr-q97g-ppwc

    Affected
    • npm @kindspells/astro-shield >= 1.2.0, < 1.3.2
    Fixed in
    1.3.2· Vendor fix available
    Issue
    Impact Versions from 1.2.0 to 1.3.1 of Astro-Shield allow to bypass the allow-lists for cross-origin resources by introducing valid integrity attributes to the injected code. This implies that the injected SRI hash would be added to the generated CSP header, which would lead the browser to believe that the injected resource is legit. To exploit this vulnerability, the attacker needs to first inject code into the rendered pages by exploiting other not-related potential vulnerabilities. Patches Version 1.3.2 provides a patch. Workarounds - To not use the middleware functionality of Astro-Shield. - To use the middleware functionality of Astro-Shield ONLY for content that cannot be controlled in any way by external users. References Are there any links users can visit to find out more?

    Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7npmAmendedPublished

    Content-Security-Policy header generation in middleware could be compromised by malicious injections

    CVE-2024-29896 · GHSA-w387-5qqw-7g8m

    Affected
    • npm @kindspells/astro-shield >= 1.2.0, <= 1.2.0
    Fixed in
    1.3.0· Vendor fix available
    Issue
    Impact When the following conditions are met: - Automated CSP headers generation for SSR content is enabled - The web application serves content that can be partially controlled by external users Then it is possible that the CSP headers generation feature might be "allow-listing" malicious injected resources like inlined JS, or references to external malicious scripts. Patches Available in version 1.3.0 . Workarounds - Do not enable CSP headers generation. - Use it only for dynamically generated content that cannot be controlled by external users in any way. References Are there any links users can visit to find out more?

    Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →