Skip to content

← Public intelligence

npm package

@ionic/core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Cross-Site Scripting in @ionic/core

    GHSA-r3xc-47qg-h929

    Affected
    • npm @ionic/core < 4.0.3; >= 4.1.0, < 4.1.3; >= 4.2.0, < 4.2.1; >= 4.3.0, < 4.3.1
    Fixed in
    4.2.14.1.34.3.14.0.3· Vendor fix available
    Issue
    Versions of @ionic/core prior to 4.0.3, 4.1.3, 4.2.1 or 4.3.1 are vulnerable to Cross-Site Scripting (XSS). The package uses the unsafe innerHTML function without sanitizing input, which may allow attackers to execute arbitrary JavaScript on the victim's browser. This issue affects the components: - <ion-alert.message - <ion-searchbar.placeholder - <ion-infinite-scroll-content.loadingText - <ion-refresher-content.pullingText - <ion-refresher-content.refershingText Recommendation - If you are using @ionic/core 4.0.x, upgrade to 4.0.3 or later. - If you are using @ionic/core 4.1.x, upgrade to 4.1.3 or later. - If you are using @ionic/core 4.2.x, upgrade to 4.2.1 or later. - If you are using @ionic/core 4.3.x, upgrade to 4.3.1 or later.

    Recommended action: Upgrade to 4.3.1, 4.2.1, 4.1.3 or 4.0.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →