UnratednpmAmendedPublished
Denial of Service in @hapi/hapi
GHSA-23vw-mhv5-grv5
- Affected
- npm @hapi/hapi < 18.4.1; >= 19.0.0, < 19.1.1
- Fixed in
- 18.4.119.1.1· Vendor fix available
- Issue
- Versions of @hapi/hapi prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. Recommendation Upgrade to versions 18.4.1, 19.1.1 or later.
Recommended action: Upgrade to 19.1.1 or 18.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.