UnratednpmAmendedPublished
Denial of Service in @hapi/ammo
GHSA-gjph-xf5q-6mfq
- Affected
- npm @hapi/ammo < 3.1.2; >= 4.0.0, < 5.0.1
- Fixed in
- 5.0.13.1.2· Vendor fix available
- Issue
- Versions of @hapi/ammo prior to 3.1.2 or 5.0.1 are vulnerable to Denial of Service. The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. Recommendation Upgrade to version 3.1.2 or 5.0.1.
Recommended action: Upgrade to 5.0.1 or 3.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.