UnratednpmAmendedPublished
Denial of Service in @hapi/accept
GHSA-9vrw-m88g-w75q
- Affected
- npm @hapi/accept >= 3.2.0, < 3.2.4; >= 4.0.0, < 5.0.1
- Fixed in
- 3.2.45.0.1· Vendor fix available
- Issue
- Versions of @hapi/accept prior to 3.2.4 or 5.0.1 are vulnerable to Denial of Service. The Accept-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. Recommendation Upgrade to version 3.2.4 or 5.0.1.
Recommended action: Upgrade to 5.0.1 or 3.2.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.