Skip to content

← Public intelligence

npm package

@enderfga/claw-orchestrator

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Claw Orchestrator has inefficient regular expression complexity via validateRegex()

    CVE-2026-10291 · GHSA-95f6-rfpg-c3w8

    Affected
    • npm @enderfga/claw-orchestrator < 3.7.1
    Fixed in
    3.7.1· Vendor fix available
    Issue
    A security vulnerability has been detected in Enderfga claw-orchestrator up to 3.7.0. The impacted element is the function validateRegex of the file claw-orchestrator/src/embedded-server.ts of the component Session Grep Endpoint. The manipulation of the argument body.pattern leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 3.7.1 is sufficient to resolve this issue. The identifier of the patch is 3f970a974c65a94555c25af9f2796f11315e4584. It is recommended to upgrade the affected component.

    Recommended action: Upgrade to 3.7.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.5npmAmendedPublished

    Claw Orchestrator is missing authentication for the component API Endpoint

    CVE-2026-10281 · GHSA-q6qc-xp4q-rjq5

    Affected
    • npm @enderfga/claw-orchestrator <= 3.5.5
    Fixed in
    3.5.6· Vendor fix available
    Issue
    A weakness has been identified in Enderfga claw-orchestrator up to 3.5.5. This affects the function EmbeddedServer of the file src/embedded-server.ts of the component API Endpoint. This manipulation causes missing authentication. The attack may be initiated remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.5.6 mitigates this issue. Patch name: d0b02a800aa0689d9428cc4cc170e0b6589fb2c3. The affected component should be upgraded.

    Recommended action: Upgrade to 3.5.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →