Skip to content

← Public intelligence

npm package

@cyanheads/git-mcp-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    @cyanheads/git-mcp-server vulnerable to command injection in several tools

    CVE-2025-53107 · GHSA-3q26-f695-pp76

    Affected
    • npm @cyanheads/git-mcp-server <= 2.1.4
    Fixed in
    2.1.5· Vendor fix available
    Issue
    A command injection vulnerability exists in the git-mcp-server MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to childprocess.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, , &&, etc.). Details The MCP Server exposes tools (gitadd, gitinit, gitlogs, etcc) to perform several git operations. An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. Below some example of vulnerable code and different ways to test this vulnerability including a real example of indirect prompt injection that can lead to arbitrary command injection. Vulnerable code The following…

    Recommended action: Upgrade to 2.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →