Medium, CVSS 6.1npmAmendedPublished
Cross-Site Scripting in @ckeditor/ckeditor5-link
CVE-2018-11093 · GHSA-gvpx-9459-w3mj
- Affected
- npm @ckeditor/ckeditor5-link >= 0.3.0, < 10.0.1
- Fixed in
- 10.0.1· Vendor fix available
- Issue
- Versions of status-board prior to 10.0.1 are vulnerable to Cross-Site Scripting. The createPreviewButton() function fails to sanitize the href attribute of a created <a tag. This may allow attackers to execute arbitrary JavaScript in a victim's browser. Recommendation Upgrade to version 10.0.1 or later.
Recommended action: Upgrade to 10.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.