High, CVSS 8.7npmAmendedPublished
@backstage/backend-common vulnerable to path traversal through symlinks
CVE-2024-26150 · GHSA-2fc9-xpp8-2g9h
- Affected
- npm @backstage/backend-common >= 0.21.0, <= 0.21.0; < 0.19.10; >= 0.20.0, < 0.20.2
- Fixed in
- 0.19.100.20.20.21.1· Vendor fix available
- Issue
- Impact Paths checks with the resolveSafeChildPath utility were not exhaustive enough, leading to risk of path traversal vulnerabilities if symlinks can be injected by attackers. Patches Patched in @backstage/backend-common version 0.21.1. Patched in @backstage/backend-common version 0.20.2. Patched in @backstage/backend-common version 0.19.10. For more information If you have any questions or comments about this advisory: - Open an issue in the Backstage repository - Visit our Discord, linked to in Backstage README
Recommended action: Upgrade to 0.21.1, 0.20.2 or 0.19.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.