High, CVSS 8.2npmAmendedPublished
@apollo/experimental-nextjs-app-support Cross-site Scripting vulnerability
CVE-2024-23841 · GHSA-rv8p-rr2h-fgpg
- Affected
- npm @apollo/experimental-nextjs-app-support <= 0.6.0
- Fixed in
- 0.7.0· Vendor fix available
- Issue
- Impact The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. This vulnerability arises from improper handling of untrusted input when @apollo/experimental-apollo-client-nextjs performs server-side rendering of HTML pages. To fix this vulnerability, we implemented appropriate escaping to prevent javascript injection into rendered pages. Patches To fix this issue, please update to version 0.7.0 or later. Workarounds There are no known workarounds for this issue. Please update to version 0.7.0
Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.