Skip to content

← Actionable
High, CVSS 7.5

Quadratic parsing of nested image wikilinks with ENABLE_WIKILINKS

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pulldown-cmark 0.13.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

With `Options::ENABLE_WIKILINKS`, handle_wikilink builds a wikilink's target from the raw text of its body: scan_wikilink_pipe walks it looking for |, then contains('\0') and from_replace_nuls walk it again. Once a wikilink is created, disable_all_links only disables Link entries, so every enclosing `![[` stays live on the wikilink stack. On `![[![[![[…]]]]]]` each of those openers then resolves in turn and rescans everything inside it, which is quadratic in the nesting depth. The event count stays tiny, because in the unpiped case each enclosing image replaces its body with a fresh text node, so all of that work is thrown away. Applications that parse untrusted Markdown with `ENABLE_WIKILINKS` set, including through `Options::all()`, are affected. The option is off by default. Parsing without it is not affected. The flaw was fixed in #1186 and released in 0.13.6.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0433

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: rustsec-2026-0433

Advisory: Quadratic parsing of nested image wikilinks with `ENABLE_WIKILINKS`
IDs: rustsec-2026-0433
Record: https://patchnext.com/advisories/rustsec-2026-0433 (revision 1, source checked 3 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pulldown-cmark 0.13.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io pulldown-cmark: affected >= 0.13.0, < 0.13.6; fixed in 0.13.6

## Suggested inspection (read-only)
- crates.io pulldown-cmark: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pulldown-cmark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0433 (OSV record RUSTSEC-2026-0433 lists affected ranges: crates.io pulldown-cmark >=0.13.0 <0.13.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…