LLVM introduces timing-vulnerable optimizations into ML-KEM and ML-DSA operations intended to be constant-time
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (orion 0.18.1, 0.17.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io orion
- Affected
- >= 0.0.0-0, < 0.17.16>= 0.18.0-0, < 0.18.1
- Fixed in
- 0.17.16, 0.18.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0426 lists affected ranges: crates.io orion >=0.0.0-0 =0.18.0-0 <0.18.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary On targets that do not have a conditional move/select operations, LLVM compiles the internal `conditional_sub_u32()` function, into one that will contain a conditional jump on secret-dependent data, which could leak information about encapsulation and signing keys. `conditional_sub_u32()` is used throughout the field arithmetic of both ML-KEM and ML-DSA.
Impact The variable-time jumps have been observed for ML-KEM and ML-DSA on: - `i586-unknown-linux-gnu` - `s390x-unknown-linux-gnu` Additionally, ML-DSA sees the vulnerable LLVM optimization on `x86_64-unknown-linux-gnu`, for `hazardous::dsa::mldsa44` and `hazardous::dsa::mldsa87`. The leakage this LLVM optimization introduces could enable recovery of cryptographic secrets. The practicality of exploiting the leakage depends on the compiler, target CPU used and how "close" to the process using the vulnerable functions the attacker is.
Resolution Upgrade to `v0.17.16` or `v0.18.1`. `conditional_sub_u32()` has been…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0426
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-r7wm-4vf2-h44w Advisory: LLVM introduces timing-vulnerable optimizations into ML-KEM and ML-DSA operations intended to be constant-time IDs: GHSA-r7wm-4vf2-h44w Record: https://patchnext.com/advisories/rustsec-2026-0426 (revision 1, source checked 31 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: orion 0.18.1, 0.17.16. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io orion: affected >= 0.0.0-0, < 0.17.16; >= 0.18.0-0, < 0.18.1; fixed in 0.17.16, 0.18.1 ## Suggested inspection (read-only) - crates.io orion: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on orion. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0426 (OSV record RUSTSEC-2026-0426 lists affected ranges: crates.io orion >=0.0.0-0 =0.18.0-0 <0.18.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…