Skip to content

← Actionable
Low, CVSS 1.8

Typed functions with i31 or nullref arguments may panic due to insufficient type-check

GHSA-3982-jqvv-277m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmtime 50.0.1, 49.0.5, 48.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io wasmtime

    Affected
    >= 47.0.0, < 48.0.8>= 49.0.0, < 49.0.5>= 50.0.0, < 50.0.1
    Fixed in
    50.0.1, 49.0.5, 48.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
1.8 · CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-3982-jqvv-277m For more information see the GitHub-hosted security advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0422

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3982-jqvv-277m

Advisory: Typed functions with `i31` or `nullref` arguments may panic due to insufficient type-check
IDs: GHSA-3982-jqvv-277m
Record: https://patchnext.com/advisories/rustsec-2026-0422 (revision 1, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wasmtime 50.0.1, 49.0.5, 48.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io wasmtime: affected >= 47.0.0, < 48.0.8; >= 49.0.0, < 49.0.5; >= 50.0.0, < 50.0.1; fixed in 50.0.1, 49.0.5, 48.0.8

## Suggested inspection (read-only)
- crates.io wasmtime: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0422 (OSV record RUSTSEC-2026-0422 lists affected ranges: crates.io wasmtime >=47.0.0 =49.0.0 =50.0.0 <50.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…