Skip to content

← Actionable
Low, CVSS 3.7

wasi-http p2: outgoing content-length can be invalid or not match body

GHSA-h4wp-g4x3-7398

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmtime-wasi-http 50.0.1, 49.0.5, 48.0.8, 36.0.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io wasmtime-wasi-http

    Affected
    >= 0.0.0-0, < 36.0.20>= 37.0.0, < 48.0.8>= 49.0.0, < 49.0.5>= 50.0.0, < 50.0.1
    Fixed in
    50.0.1, 36.0.20, 49.0.5, 48.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-h4wp-g4x3-7398 For more information see the GitHub-hosted security advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0421

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-h4wp-g4x3-7398

Advisory: wasi-http p2: outgoing content-length can be invalid or not match body
IDs: GHSA-h4wp-g4x3-7398
Record: https://patchnext.com/advisories/rustsec-2026-0421 (revision 1, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wasmtime-wasi-http 50.0.1, 49.0.5, 48.0.8, 36.0.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io wasmtime-wasi-http: affected >= 0.0.0-0, < 36.0.20; >= 37.0.0, < 48.0.8; >= 49.0.0, < 49.0.5; >= 50.0.0, < 50.0.1; fixed in 50.0.1, 36.0.20, 49.0.5, 48.0.8

## Suggested inspection (read-only)
- crates.io wasmtime-wasi-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmtime-wasi-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0421 (OSV record RUSTSEC-2026-0421 lists affected ranges: crates.io wasmtime-wasi-http >=0.0.0-0 =37.0.0 =49.0.0 =50.0.0 <50.0.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…