Unbounded memory use on large request bodies
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (juniper_warp 0.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io juniper_warp
- Affected
- >= 0.0.0-0, < 0.9.1
- Fixed in
- 0.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0419 lists affected ranges: crates.io juniper_warp >=0.0.0-0 <0.9.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The `make_graphql_filter()` and `make_graphql_filter_sync()` filters of `juniper_warp` read the whole body of a POST request into memory before they parsed the body. The filters had no limit on the size of the body. A client could thus send a large body and exhaust the memory of the server. The request needs no authentication. `juniper_warp` 0.9.1 reads at most 2 MiB of a request body by default. The filters respond with `413 Payload Too Large` to larger bodies. `make_graphql_filter_with_body_limit()` and `make_graphql_filter_sync_with_body_limit()` set another limit.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0419
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fj3h-2jc3-973v Advisory: Unbounded memory use on large request bodies IDs: GHSA-fj3h-2jc3-973v Record: https://patchnext.com/advisories/rustsec-2026-0419 (revision 1, source checked 30 Oct 2026, 07:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: juniper_warp 0.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io juniper_warp: affected >= 0.0.0-0, < 0.9.1; fixed in 0.9.1 ## Suggested inspection (read-only) - crates.io juniper_warp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on juniper_warp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0419 (OSV record RUSTSEC-2026-0419 lists affected ranges: crates.io juniper_warp >=0.0.0-0 <0.9.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…