Stack overflow on deeply nested GraphQL documents
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (juniper 0.17.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io juniper
- Affected
- >= 0.0.0-0, < 0.17.2
- Fixed in
- 0.17.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0416 lists affected ranges: crates.io juniper >=0.0.0-0 <0.17.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The parser of `juniper` called itself once for each level of nesting in a GraphQL document. The parser had no limit on the nesting depth. Deeply nested selection sets, input values, and list types thus overflowed the stack of the thread that parsed the document. Validation and execution followed fragment spreads in the same recursive way. Long chains of fragment spreads thus overflowed the stack in validation and execution. A stack overflow aborts the whole process. One request can thus stop a server and drop all other requests in progress. The request needs no authentication. `juniper` 0.17.2 rejects documents that nest deeper than 64 levels or contain more than 15,000 tokens. `RootNode::limit_depth()` and `RootNode::limit_tokens()` change the limits.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0416
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-34cw-x8g7-rcv5 Advisory: Stack overflow on deeply nested GraphQL documents IDs: GHSA-34cw-x8g7-rcv5 Record: https://patchnext.com/advisories/rustsec-2026-0416 (revision 1, source checked 30 Oct 2026, 07:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: juniper 0.17.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io juniper: affected >= 0.0.0-0, < 0.17.2; fixed in 0.17.2 ## Suggested inspection (read-only) - crates.io juniper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on juniper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0416 (OSV record RUSTSEC-2026-0416 lists affected ranges: crates.io juniper >=0.0.0-0 <0.17.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…