Skip to content

← Actionable
High, CVSS 7.8

Arbitrary code execution when rerunning tests from a portable recording

GHSA-vc25-qg58-w57c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cargo-nextest 0.9.150), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io cargo-nextest

    Affected
    >= 0.9.125, < 0.9.150
    Fixed in
    0.9.150

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Nextest versions between 0.9.125 and 0.9.149 (inclusive) allow the `cargo nextest run --rerun` (or `-R`) command with a malicious portable recording to run arbitrary code during the build. The result is arbitrary code execution with the privileges of the user running `cargo nextest`. This vulnerability requires that the experimental run recording functionality is enabled. An attacker can plausibly trick a victim into enabling this feature.

Details Nextest's portable recordings contain build scope arguments. These arguments are deserialized verbatim from portable recordings, and are not validated. As a result, it is possible to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0412

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vc25-qg58-w57c

Advisory: Arbitrary code execution when rerunning tests from a portable recording
IDs: GHSA-vc25-qg58-w57c
Record: https://patchnext.com/advisories/rustsec-2026-0412 (revision 1, source checked 28 Oct 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cargo-nextest 0.9.150. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io cargo-nextest: affected >= 0.9.125, < 0.9.150; fixed in 0.9.150

## Suggested inspection (read-only)
- crates.io cargo-nextest: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cargo-nextest.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0412 (OSV record RUSTSEC-2026-0412 lists affected ranges: crates.io cargo-nextest >=0.9.125 <0.9.150 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…