Skip to content

← Actionable
Unratedamended

Double free in DCtx::try_clone

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zstd-safe 8.2.0, 7.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io zstd-safe

    Affected
    >= 4.1.4, < 7.4.0>= 8.0.0-0, < 8.2.0
    Fixed in
    7.4.0, 8.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

`DCtx::try_clone` (`experimental` feature, deprecated) is a plain copy of the C context. A context owning a dictionary (from `load_dictionary`, `ref_prefix` or `init_using_dict`) or a dictionary table (`ref_ddict` with `RefMultipleDDicts`) ended up with both copies freeing it. A context cloned mid-frame resumed on uninitialized stream state. The clone also silently lost the `WindowLogMax` limit. The flaw was corrected by refusing to clone such contexts, and by carrying over the parameters the copy leaves out.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record RUSTSEC-2026-0404

  2. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0404

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: rustsec-2026-0404

Advisory: Double free in `DCtx::try_clone`
IDs: rustsec-2026-0404
Record: https://patchnext.com/advisories/rustsec-2026-0404 (revision 2, source checked 3 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zstd-safe 8.2.0, 7.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io zstd-safe: affected >= 4.1.4, < 7.4.0; >= 8.0.0-0, < 8.2.0; fixed in 7.4.0, 8.2.0

## Suggested inspection (read-only)
- crates.io zstd-safe: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zstd-safe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0404 (OSV record RUSTSEC-2026-0404 lists affected ranges: crates.io zstd-safe >=4.1.4 <8.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0404 (OSV record RUSTSEC-2026-0404 lists affected ranges: crates.io zstd-safe >=4.1.4 =8.0.0-0 <8.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…