Skip to content

← Actionable
Unratedamended

Uninitialized memory exposed when streaming decompression of a legacy frame fails

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zstd-safe 8.2.0, 7.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io zstd-safe

    Affected
    >= 4.0.0, < 7.4.0>= 8.0.0-0, < 8.2.0
    Fixed in
    7.4.0, 8.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

When decompression fails inside a legacy (zstd v0.4 to v0.7) frame, the bundled zstd library reports the output buffer as fully written although nothing was written. `DCtx::decompress_stream` committed that position even on error, and for a `Vec ` destination this extended the vector's length over uninitialized memory. Legacy support is enabled by default. A 5- or 6-byte corrupt legacy frame is enough: through `zstd::stream::write::Decoder`, up to 32 KiB of stale heap memory is then passed to the wrapped writer on the next `write()` or `flush()`, or when an `auto_flush()`/`on_flush()` decoder is dropped. Whether this reaches an attacker depends on where the application sends the decompressed output. `zstd::stream::read::Decoder`, `zstd::decode_all` and the bulk API are not affected. Before zstd-safe 4.0.0, output buffers could only be initialized slices. The zstd crate's own writer had the same flaw from 0.4.22 to 0.7.x, which is covered by a separate advisory. The flaw was corrected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record RUSTSEC-2026-0403

  2. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0403

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: rustsec-2026-0403

Advisory: Uninitialized memory exposed when streaming decompression of a legacy frame fails
IDs: rustsec-2026-0403
Record: https://patchnext.com/advisories/rustsec-2026-0403 (revision 2, source checked 3 Nov 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zstd-safe 8.2.0, 7.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io zstd-safe: affected >= 4.0.0, < 7.4.0; >= 8.0.0-0, < 8.2.0; fixed in 7.4.0, 8.2.0

## Suggested inspection (read-only)
- crates.io zstd-safe: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zstd-safe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0403 (OSV record RUSTSEC-2026-0403 lists affected ranges: crates.io zstd-safe >=4.0.0 <8.2.0 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0403 (OSV record RUSTSEC-2026-0403 lists affected ranges: crates.io zstd-safe >=4.0.0 =8.0.0-0 <8.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…