wasi-http p3: Guests can set incorrect content-length for spliced response bodies
CVE-2026-121439GHSA-9prg-84vf-g5fc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmtime-wasi-http 49.0.4, 48.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io wasmtime-wasi-http
- Affected
- >= 46.0.0, < 48.0.7>= 49.0.0, < 49.0.4
- Fixed in
- 49.0.4, 48.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0375 lists affected ranges: crates.io wasmtime-wasi-http >=46.0.0 =49.0.0 <49.0.4 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-9prg-84vf-g5fc For more information see the GitHub-hosted security advisory.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record RUSTSEC-2026-0375
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0375
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-121439 Advisory: `wasi-http` p3: Guests can set incorrect content-length for spliced response bodies IDs: CVE-2026-121439, GHSA-9prg-84vf-g5fc Record: https://patchnext.com/advisories/rustsec-2026-0375 (revision 2, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wasmtime-wasi-http 49.0.4, 48.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io wasmtime-wasi-http: affected >= 46.0.0, < 48.0.7; >= 49.0.0, < 49.0.4; fixed in 49.0.4, 48.0.7 ## Suggested inspection (read-only) - crates.io wasmtime-wasi-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wasmtime-wasi-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0375 (OSV record RUSTSEC-2026-0375 lists affected ranges: crates.io wasmtime-wasi-http >=46.0.0 =49.0.0 <49.0.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…