Skip to content

← Actionable
Medium, CVSS 5.3amended

wasi-http: Request with long url before query parameter crashes host

CVE-2026-119131GHSA-w36r-2hch-9xp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmtime-wasi-http 49.0.3, 48.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io wasmtime-wasi-http

    Affected
    >= 46.0.0, < 48.0.6>= 49.0.0, < 49.0.3
    Fixed in
    48.0.6, 49.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-119131: 0.30% estimated exploitation activity in the next 30 days; percentile 23.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This is an entry in the RustSec database for the Wasmtime security advisory located at https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-w36r-2hch-9xp9 For more information see the GitHub-hosted security advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record RUSTSEC-2026-0351

  2. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0351

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-119131

Advisory: `wasi-http`: Request with long url before query parameter crashes host
IDs: CVE-2026-119131, GHSA-w36r-2hch-9xp9
Record: https://patchnext.com/advisories/rustsec-2026-0351 (revision 2, source checked 30 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wasmtime-wasi-http 49.0.3, 48.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io wasmtime-wasi-http: affected >= 46.0.0, < 48.0.6; >= 49.0.0, < 49.0.3; fixed in 48.0.6, 49.0.3

## Suggested inspection (read-only)
- crates.io wasmtime-wasi-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmtime-wasi-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0351 (OSV record RUSTSEC-2026-0351 lists affected ranges: crates.io wasmtime-wasi-http >=46.0.0 =49.0.0 <49.0.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…