Skip to content

← Actionable
Low, CVSS 3.7amended

Rustls: Brotli certificate decompression can allocate an attacker-controlled amount of memory up to 1 GiB before authentication.

GHSA-h2v8-394m-p7vv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rustls 0.24.0-dev.2, 0.23.46), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io rustls

    Affected
    < 0.23.46>= 0.24.0-dev.1, < 0.24.0-dev.2
    Fixed in
    0.24.0-dev.2, 0.23.46

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The built-in (but disabled by default) Brotli certificate decoder bounds the output buffer but accepts an input-selected history window. A header of five bytes can specify a 1 GiB window allocation. A peer can abort a process whose allocator cannot satisfy that request. A client must enable Brotli and connect to the peer; a server must enable Brotli and request a client certificate. Neither direction requires a trusted attacker certificate.

Details rustls calls `BrotliDecompress` which enables Brotli's large-window extension. rustls applies a limit to certificates, but this applies to the decompressed result, and not to any internal allocations the process requires.

Impact Client applications that enable the `brotli` feature will be vulnerable to malicious servers. Server applications that enable the `brotli` feature and enable client authentication will be vulnerable to malicious clients. Potential for denial of service due to memory exhaustion from peers sending…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-h2v8-394m-p7vv

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-h2v8-394m-p7vv

  3. Revision 1 · created ·

    Published from osv record RUSTSEC-2026-0348

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-h2v8-394m-p7vv

Advisory: Rustls: Brotli certificate decompression can allocate an attacker-controlled amount of memory up to 1 GiB before authentication.
IDs: GHSA-h2v8-394m-p7vv
Record: https://patchnext.com/advisories/rustsec-2026-0348 (revision 3, source checked 28 Oct 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rustls 0.24.0-dev.2, 0.23.46. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io rustls: affected < 0.23.46; >= 0.24.0-dev.1, < 0.24.0-dev.2; fixed in 0.24.0-dev.2, 0.23.46

## Suggested inspection (read-only)
- crates.io rustls: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rustls.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0348 (OSV record RUSTSEC-2026-0348 lists affected ranges: crates.io rustls >=0.23.9 <0.23.46 (fixed))
- Verified: https://github.com/advisories/GHSA-h2v8-394m-p7vv (GitHub-reviewed advisory GHSA-h2v8-394m-p7vv lists affected ranges: crates.io rustls >=0 =0.24.0-dev.1 <0.24.0-dev.2)
- Verified: https://osv.dev/vulnerability/GHSA-h2v8-394m-p7vv (OSV record GHSA-h2v8-394m-p7vv lists affected ranges: crates.io rustls >=0 =0.24.0-dev.1 <0.24.0-dev.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…