Poly1305 panics or computes a wrong tag on attacker-chosen messages of 64 bytes or more
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ic-cipher 0.2.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io ic-cipher
- Affected
- >= 0.2.5, < 0.2.20
- Fixed in
- 0.2.20
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0337 lists affected ranges: crates.io ic-cipher >=0.2.5 <0.2.20 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
`Poly1305` in `ic-cipher` absorbs messages of 64 bytes or more four blocks at a time, summing four products before one reduction. From 0.2.5 to 0.2.19 the reduction kept its carries in 32-bit integers, which four summed products can overflow when the message's bytes are large. This affects `Poly1305` and `ChaCha20Poly1305`, and everything built on them: the TLS and QUIC ChaCha20-Poly1305 suites in `ic-rustls`, HPKE with that cipher in `ic-hpke`, and the re-exports in `ic-mac` and `ironcrypto`. What happens depends on how the crate was compiled: - With overflow checks on (any debug build, or a release profile with `overflow-checks = true`) the multiplication panics, and under `panic = "abort"` the process ends. The tag is computed over the ciphertext before it is compared, so this happens before authentication and without the key: anyone who can deliver a ChaCha20-Poly1305 ciphertext to be opened can trigger it. - With overflow checks off (Cargo's default for release builds) the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0337
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-xr22-8pqp-gwfh Advisory: Poly1305 panics or computes a wrong tag on attacker-chosen messages of 64 bytes or more IDs: GHSA-xr22-8pqp-gwfh Record: https://patchnext.com/advisories/rustsec-2026-0337 (revision 1, source checked 23 Oct 2026, 22:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ic-cipher 0.2.20. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ic-cipher: affected >= 0.2.5, < 0.2.20; fixed in 0.2.20 ## Suggested inspection (read-only) - crates.io ic-cipher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ic-cipher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0337 (OSV record RUSTSEC-2026-0337 lists affected ranges: crates.io ic-cipher >=0.2.5 <0.2.20 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…