uncbv: archive extraction is vulnerable to path traversal (zip-slip)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uncbv 0.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io uncbv
- Affected
- >= 0.0.0-0, < 0.3.1
- Fixed in
- 0.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0307 lists affected ranges: crates.io uncbv >=0.0.0-0 <0.3.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary `uncbv extract` writes each archive entry to `output_dir.join(entry_filename)` using the filename stored in the archive with no check for `..` components or absolute paths. A malicious `.cbv` / `.cbz` archive whose entry name contains `../` (or an absolute path) can therefore cause files to be written outside the output directory chosen by the user. This is a "zip-slip" / directory-traversal arbitrary file write (CWE-22).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0307
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: rustsec-2026-0307 Advisory: `uncbv`: archive extraction is vulnerable to path traversal (zip-slip) IDs: rustsec-2026-0307 Record: https://patchnext.com/advisories/rustsec-2026-0307 (revision 1, source checked 23 Oct 2026, 22:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uncbv 0.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io uncbv: affected >= 0.0.0-0, < 0.3.1; fixed in 0.3.1 ## Suggested inspection (read-only) - crates.io uncbv: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uncbv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0307 (OSV record RUSTSEC-2026-0307 lists affected ranges: crates.io uncbv >=0.0.0-0 <0.3.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…