Remote Denial of Service via malformed NIP-04 IV
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nostr 0.45.0-alpha.6, 0.44.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io nostr
- Affected
- >= 0.0.0-0, < 0.44.6>= 0.45.0-alpha.1, < 0.45.0-alpha.6
- Fixed in
- 0.44.6, 0.45.0-alpha.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0219 lists affected ranges: crates.io nostr >=0.0.0-0 =0.45.0-alpha.1 <0.45.0-alpha.6 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The `nostr` crate did not validate the length of the initialization vector decoded from the `?iv=` portion of a NIP-04 encrypted message. The decoded IV was converted from a byte slice to the 16-byte AES-CBC IV type using a conversion that asserts the slice length. As a result, an IV whose decoded length was not exactly 16 bytes caused a panic before ciphertext decryption. For example, `?iv=AAAA` decodes to a three-byte IV and triggers the panic. Applications that decrypt untrusted NIP-04 content are affected. The issue is also reachable through NIP-47 (Nostr Wallet Connect), where response and notification events from a malicious or compromised wallet service are passed to NIP-04 decryption. If the panic is not isolated, a crafted event can terminate the application or disrupt message processing, causing a denial of service. The issue does not affect confidentiality or integrity. The flaw was corrected by converting the decoded IV to `[u8; 16]` using a checked conversion. Invalid IV…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0219
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-xg7c-246g-6qpv Advisory: Remote Denial of Service via malformed NIP-04 IV IDs: GHSA-xg7c-246g-6qpv Record: https://patchnext.com/advisories/rustsec-2026-0219 (revision 1, source checked 23 Oct 2026, 22:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nostr 0.45.0-alpha.6, 0.44.6. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io nostr: affected >= 0.0.0-0, < 0.44.6; >= 0.45.0-alpha.1, < 0.45.0-alpha.6; fixed in 0.44.6, 0.45.0-alpha.6 ## Suggested inspection (read-only) - crates.io nostr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nostr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0219 (OSV record RUSTSEC-2026-0219 lists affected ranges: crates.io nostr >=0.0.0-0 =0.45.0-alpha.1 <0.45.0-alpha.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…