Skip to content

← Actionable
Medium, CVSS 6.5amended

Kite Kubernetes proxy path traversal allows authenticated users to bypass RBAC and read cluster-wide resources

GHSA-c534-2w9c-x7fm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/zxh326/kite 0.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Kite versions 0.6.9 through 0.14.0 authorize Kubernetes proxy requests against the pod or service identified by the original route parameters. Encoded path traversal segments can cause the upstream URL to resolve to a different Kubernetes API endpoint after authorization. Impact An authenticated user with get permission on pods or services in one namespace can cause Kite to issue GET requests to Kubernetes API endpoints outside that namespace using Kite's service account. With Kite's default Helm RBAC configuration, this allows cluster-wide resource disclosure, including Secrets. The validated impact is confidentiality only; resource modification and denial of service were not demonstrated. Deployments using a restricted Kite service account are affected only up to the permissions granted to that service account. Technical details The authorization check is performed against the original namespace and kind route parameters. The proxy path is subsequently decoded and passed to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c534-2w9c-x7fm

  2. Revision 1 · created ·

    Published from osv record GO-2026-6105

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-c534-2w9c-x7fm

Advisory: Kite Kubernetes proxy path traversal allows authenticated users to bypass RBAC and read cluster-wide resources
IDs: GHSA-c534-2w9c-x7fm
Record: https://patchnext.com/advisories/go-2026-6105 (revision 2, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/zxh326/kite 0.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/zxh326/kite: affected >= 0.6.9, <= 0.14.0; fixed in 0.14.1

## Suggested inspection (read-only)
- Go github.com/zxh326/kite: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/zxh326/kite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6105 (OSV record GO-2026-6105 lists affected ranges: Go github.com/zxh326/kite >=0.6.9 <0.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-c534-2w9c-x7fm (GitHub-reviewed advisory GHSA-c534-2w9c-x7fm lists affected ranges: Go github.com/zxh326/kite >=0.6.9 <=0.14.0)

Commands are suggestions: review each one before running it.

Loading voting…