Skip to content

← Actionable
Medium, CVSS 6.0

SurrealDB vulnerable to Denial of Service through scripting function memory edge case

GHSA-xx7m-69ff-9crp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 3.0.0-beta.3, 2.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    < 2.6.1>= 3.0.0-alpha.8, < 3.0.0-beta.3
    Fixed in
    3.0.0-beta.3, 2.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

In SurrealDB instances with the scripting capability enabled (--allow-scripting), users with the ability to run arbitrary queries can trigger a server crash due to a memory-safety bug in the underlying JS engine. The SurrealDB instance terminates instantly, requiring a manual restart. The query consists of using built-in string functions to construct a large string and passing it to the JavaScript runtime for compilation. The exact string size required to trigger the crash varies between SurrealDB versions. Whilst exploiting the vulnerability requires users to be able to run arbitrary queries, if guest access (--allow-guests), is enabled, then guests can perform this attack. Impact Any user able to execute queries on a SurrealDB instance with scripting enabled (--allow-scripting) can cause complete denial of service. The server process terminates immediately without graceful shutdown. The underlying cause of the vulnerability is a null pointer dereference in the QuickJS-NG v0.8…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xx7m-69ff-9crp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xx7m-69ff-9crp

Advisory: SurrealDB vulnerable to Denial of Service through scripting function memory edge case
IDs: GHSA-xx7m-69ff-9crp
Record: https://patchnext.com/advisories/ghsa-xx7m-69ff-9crp (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 3.0.0-beta.3, 2.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected < 2.6.1; >= 3.0.0-alpha.8, < 3.0.0-beta.3; fixed in 3.0.0-beta.3, 2.6.1

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xx7m-69ff-9crp (GitHub-reviewed advisory GHSA-xx7m-69ff-9crp lists affected ranges: crates.io surrealdb >=0 =3.0.0-alpha.8 <3.0.0-beta.3)

Commands are suggestions: review each one before running it.

Loading voting…