Inefficient Regular Expression Complexity in Validator.js
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (validator 13.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm validator
- Affected
- >= 11.1.0, < 13.7.0
- Fixed in
- 13.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xx4c-jj58-r7x6 lists affected ranges: npm validator >=11.1.0 <13.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xx4c-jj58-r7x6 lists affected ranges: npm validator >=11.1.0 <13.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Versions of validator prior to 13.7.0 are affected by an inefficient Regular Expression complexity when using the rtrim and trim sanitizers. Patches The problem has been patched in validator 13.7.0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xx4c-jj58-r7x6
- Revision 1 · created ·
Published from osv record GHSA-xx4c-jj58-r7x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-xx4c-jj58-r7x6 Advisory: Inefficient Regular Expression Complexity in Validator.js IDs: GHSA-xx4c-jj58-r7x6 Record: https://patchnext.com/advisories/ghsa-xx4c-jj58-r7x6 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: validator 13.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm validator: affected >= 11.1.0, < 13.7.0; fixed in 13.7.0 ## Suggested inspection (read-only) - `npm ls validator --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on validator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xx4c-jj58-r7x6 (OSV record GHSA-xx4c-jj58-r7x6 lists affected ranges: npm validator >=11.1.0 <13.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xx4c-jj58-r7x6 (GitHub-reviewed advisory GHSA-xx4c-jj58-r7x6 lists affected ranges: npm validator >=11.1.0 <13.7.0) Commands are suggestions: review each one before running it.
Loading voting…