CakePHP vulnerable to Cross-site Scripting in some development error pages
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 3.6.4, 3.5.17, 3.4.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cakephp/cakephp
- Affected
- >= 3.4.0, < 3.4.14>= 3.5.0, < 3.5.17>= 3.6.0, < 3.6.4
- Fixed in
- 3.4.14, 3.5.17, 3.6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xwhj-pqcg-8rcr lists affected ranges: Packagist cakephp/cakephp >=3.4.0 =3.5.0 =3.6.0 <3.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only missing route and duplicate named route error pages.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xwhj-pqcg-8rcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-xwhj-pqcg-8rcr Advisory: CakePHP vulnerable to Cross-site Scripting in some development error pages IDs: GHSA-xwhj-pqcg-8rcr Record: https://patchnext.com/advisories/ghsa-xwhj-pqcg-8rcr (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 3.6.4, 3.5.17, 3.4.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cakephp/cakephp: affected >= 3.4.0, < 3.4.14; >= 3.5.0, < 3.5.17; >= 3.6.0, < 3.6.4; fixed in 3.4.14, 3.5.17, 3.6.4 ## Suggested inspection (read-only) - Packagist cakephp/cakephp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cakephp/cakephp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xwhj-pqcg-8rcr (GitHub-reviewed advisory GHSA-xwhj-pqcg-8rcr lists affected ranges: Packagist cakephp/cakephp >=3.4.0 =3.5.0 =3.6.0 <3.6.4) Commands are suggestions: review each one before running it.
Loading voting…