Skip to content

← Actionable
Medium, CVSS 4.2amended

Actual Sync-server Gocardless service is logging sensitive data including bearer tokens and account numbers

GHSA-xvp7-8vm8-xfxx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 25.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The GoCardless components in Actualbudget in are logging responses to STDOUT in a parsed format using console.logand console.debug (Which in this version of node is an alias for console.log). This is exposing sensitive information in log files including, but not limited to: - Gocardless bearer tokens. - Account IBAN and Bank Account numbers. - PII of the account holder. - Transaction details (Payee bank information, Recipient account numbers, Transaction IDs)... Details Whenever GoCardless responds to a request, the payload is printed to the debug log: https://github.com/actualbudget/actual/blob/36c40d90d2fe09eb1f25a6e2f77f6dd40638b267/packages/sync-server/src/app-gocardless/banks/integration-bank.js#L25-L27 This in turn logs the following information to Docker (all values removed here. These fields are possibly dependent on what is returned by each institution so may differ):…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xvp7-8vm8-xfxx

  2. Revision 1 · created ·

    Published from osv record GHSA-xvp7-8vm8-xfxx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xvp7-8vm8-xfxx

Advisory: Actual Sync-server Gocardless service is logging sensitive data including bearer tokens and account numbers
IDs: GHSA-xvp7-8vm8-xfxx
Record: https://patchnext.com/advisories/ghsa-xvp7-8vm8-xfxx (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 25.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @actual-app/sync-server: affected <= 25.10.0; fixed in 25.11.0

## Suggested inspection (read-only)
- `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @actual-app/sync-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xvp7-8vm8-xfxx (OSV record GHSA-xvp7-8vm8-xfxx lists affected ranges: npm @actual-app/sync-server >=0 <25.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xvp7-8vm8-xfxx (GitHub-reviewed advisory GHSA-xvp7-8vm8-xfxx lists affected ranges: npm @actual-app/sync-server >=0 <=25.10.0)

Commands are suggestions: review each one before running it.

Loading voting…