Skip to content

← Actionable
Medium, CVSS 4.2

@dynatrace-oss/dynatrace-mcp-server has a workflow template injection via create_workflow_for_notification

GHSA-xrmj-5g4g-8987

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dynatrace-oss/dynatrace-mcp-server 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A template injection vulnerability in the createworkflowfornotification tool lets a caller embed Jinja2 expressions that the Dynatrace workflow engine evaluates at runtime, exfiltrating event data to attacker-controlled destinations through a workflow that persists in the tenant after the MCP session ends. Details The createworkflowfornotification tool interpolates three caller-supplied parameters (teamName, problemType, channel) directly into a Dynatrace Workflow definition. Dynatrace Workflows use Jinja2 templating: per the official documentation, {{ ... }} expressions in action inputs are evaluated at workflow runtime for every action except Run Javascript (which is carved out specifically to avoid code injection). A caller can therefore supply, for example, teamName = "{{ event() }}" and have the workflow engine evaluate that expression at runtime, serialising the full event object into the message body delivered to the Slack channel. The vulnerable code is in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xrmj-5g4g-8987

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xrmj-5g4g-8987

Advisory: @dynatrace-oss/dynatrace-mcp-server has a workflow template injection via create_workflow_for_notification
IDs: GHSA-xrmj-5g4g-8987
Record: https://patchnext.com/advisories/ghsa-xrmj-5g4g-8987 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @dynatrace-oss/dynatrace-mcp-server 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @dynatrace-oss/dynatrace-mcp-server: affected < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls @dynatrace-oss/dynatrace-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @dynatrace-oss/dynatrace-mcp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xrmj-5g4g-8987 (GitHub-reviewed advisory GHSA-xrmj-5g4g-8987 lists affected ranges: npm @dynatrace-oss/dynatrace-mcp-server >=0 <2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…