Skip to content

← Actionable
Medium, CVSS 6.3amended

@grackle-ai/powerline Runs Without Authentication by Default

GHSA-xq7h-vwjp-5vrh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grackle-ai/powerline 0.70.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact When --token is not provided and GRACKLEPOWERLINETOKEN is not set, the PowerLine gRPC server runs with zero authentication. A warning is logged ("NO AUTH (development only)") but nothing prevents deployment in this state. Any client that can reach the PowerLine port can spawn agent sessions, access credential tokens, and execute code. The default binding is 127.0.0.1 (loopback only), which limits exposure to the local machine. However, if PowerLine is accidentally exposed on a network (e.g., in a container or via port forwarding), the impact is critical. Affected code: - packages/powerline/src/index.ts:46 — token defaults to empty string - packages/powerline/src/index.ts:63-76 — auth interceptor is only added when token is truthy Patches 0.70.1 Fix: Require an explicit --no-auth flag to run without authentication, rather than defaulting to no auth when the token is empty. Throw an error if starting without a token and without --no-auth. Workarounds Always provide --token or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xq7h-vwjp-5vrh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xq7h-vwjp-5vrh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xq7h-vwjp-5vrh

Advisory: @grackle-ai/powerline Runs Without Authentication by Default
IDs: GHSA-xq7h-vwjp-5vrh
Record: https://patchnext.com/advisories/ghsa-xq7h-vwjp-5vrh (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @grackle-ai/powerline 0.70.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @grackle-ai/powerline: affected <= 0.70.0; fixed in 0.70.1

## Suggested inspection (read-only)
- `npm ls @grackle-ai/powerline --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @grackle-ai/powerline.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xq7h-vwjp-5vrh (OSV record GHSA-xq7h-vwjp-5vrh lists affected ranges: npm @grackle-ai/powerline >=0 <0.70.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xq7h-vwjp-5vrh (GitHub-reviewed advisory GHSA-xq7h-vwjp-5vrh lists affected ranges: npm @grackle-ai/powerline >=0 <=0.70.0)

Commands are suggestions: review each one before running it.

Loading voting…