Skip to content

← Actionable
Low, CVSS 2.1amended

REDAXO has reflected XSS backend packages API via function parameter (CSRF token required)

CVE-2026-117538GHSA-xq4j-g85q-wf97

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (redaxo/source 5.21.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-117538: 0.18% estimated exploitation activity in the next 30 days; percentile 7.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A reflected XSS vulnerability has been identified in the REDAXO backend. The `function` parameter is concatenated into an API error message and rendered without HTML escaping. ---

Details Root cause User input `function` is injected into an exception message, then rendered by `rex_view::error()` which delegates to `rex_view::message()` without HTML escaping. Vulnerable code (`redaxo/src/core/lib/packages/api_package.php`) : ```php $function = rex_request('function', 'string'); throw new rex_api_exception('Unknown package function "' . $function . '"!'); ``` Sink (`redaxo/src/core/lib/view.php`) : ```php return ' ' . $message . ' '; ``` Source -> sink flow * Source: `function` (GET) * Propagation: concatenated into the exception message * Sink: rendered via `rex_view::error()` -> `rex_view::message()` without escaping Authentication required: yes (backend session) ---

PoC - Exploit ```python #!/usr/bin/env python3 import re import…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-xq4j-g85q-wf97

  2. Revision 1 · created ·

    Published from ghsa record GHSA-xq4j-g85q-wf97

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-117538

Advisory: REDAXO has reflected XSS backend packages API via function parameter (CSRF token required)
IDs: CVE-2026-117538, GHSA-xq4j-g85q-wf97
Record: https://patchnext.com/advisories/ghsa-xq4j-g85q-wf97 (revision 2, source checked 28 Oct 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: redaxo/source 5.21.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist redaxo/source: affected < 5.21.0; fixed in 5.21.0

## Suggested inspection (read-only)
- Packagist redaxo/source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on redaxo/source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xq4j-g85q-wf97 (OSV record GHSA-xq4j-g85q-wf97 lists affected ranges: Packagist redaxo/source >=0 <5.21.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xq4j-g85q-wf97 (GitHub-reviewed advisory GHSA-xq4j-g85q-wf97 lists affected ranges: Packagist redaxo/source >=0 <5.21.0)

Commands are suggestions: review each one before running it.

Loading voting…