io.netty:netty-codec-http2 vulnerable to HTTP/2 Rapid Reset Attack
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http2 4.1.100.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-http2
- Affected
- < 4.1.100.Final
- Fixed in
- 4.1.100.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xpw8-rcwv-8f8p lists affected ranges: Maven io.netty:netty-codec-http2 >=0 <4.1.100.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A client might overload the server by issue frequent RST frames. This can cause a massive amount of load on the remote system and so cause a DDOS attack. Impact This is a DDOS attack, any http2 server is affected and so you should update as soon as possible. Patches This is patched in version 4.1.100.Final. Workarounds A user can limit the amount of RST frames that are accepted per connection over a timeframe manually using either an own Http2FrameListener implementation or an ChannelInboundHandler implementation (depending which http2 API is used). References - https://www.cve.org/CVERecord?id=CVE-2023-44487 - https://blog.cloudflare.com/technical-breakdown-http2-rapid-reset-ddos-attack/ - https://cloud.google.com/blog/products/identity-security/google-cloud-mitigated-largest-ddos-attack-peaking-above-398-million-rps/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xpw8-rcwv-8f8p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-xpw8-rcwv-8f8p Advisory: io.netty:netty-codec-http2 vulnerable to HTTP/2 Rapid Reset Attack IDs: GHSA-xpw8-rcwv-8f8p Record: https://patchnext.com/advisories/ghsa-xpw8-rcwv-8f8p (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http2 4.1.100.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-http2: affected < 4.1.100.Final; fixed in 4.1.100.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-http2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-http2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xpw8-rcwv-8f8p (GitHub-reviewed advisory GHSA-xpw8-rcwv-8f8p lists affected ranges: Maven io.netty:netty-codec-http2 >=0 <4.1.100.Final) Commands are suggestions: review each one before running it.
Loading voting…