Skip to content

← Actionable
High, CVSS 8.1amended

PsiTransfer has Zip Slip Path Traversal via TAR Archive Download

GHSA-xphh-5v4r-r3rx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (psitransfer 2.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A Zip Slip vulnerability in PsiTransfer allows an unauthenticated attacker to upload files with path traversal sequences in the filename (e.g. ../../../.ssh/authorizedkeys). When a victim downloads the bucket as a .tar.gz archive and extracts it, malicious files are written outside the intended directory, potentially leading to RCE. Details The vulnerability exists in the archive download functionality in lib/endpoints.js where user controlled metadata.name is used directly without sanitization when creating TAR archive entries. PoC I. Upload file with malicious filename (no authentication required). II. Complete upload with PATCH III. Victim downloads and extracts TAR Impact Arbitrary File Write: Attacker can write files anywhere on victim's filesystem when they extract the archive. RCE: By targeting ~/.bashrc, ~/.ssh/authorizedkeys, cron directories etc... No Authentication Required: Default configuration has uploadPass: false. Social Engineering Vector: Attacker sends…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xphh-5v4r-r3rx

  2. Revision 1 · created ·

    Published from osv record GHSA-xphh-5v4r-r3rx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xphh-5v4r-r3rx

Advisory: PsiTransfer has Zip Slip Path Traversal via TAR Archive Download
IDs: GHSA-xphh-5v4r-r3rx
Record: https://patchnext.com/advisories/ghsa-xphh-5v4r-r3rx (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: psitransfer 2.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm psitransfer: affected < 2.3.1; fixed in 2.3.1

## Suggested inspection (read-only)
- `npm ls psitransfer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on psitransfer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xphh-5v4r-r3rx (OSV record GHSA-xphh-5v4r-r3rx lists affected ranges: npm psitransfer >=0 <2.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xphh-5v4r-r3rx (GitHub-reviewed advisory GHSA-xphh-5v4r-r3rx lists affected ranges: npm psitransfer >=0 <2.3.1)

Commands are suggestions: review each one before running it.

Loading voting…