Skip to content

← Actionable
Medium, CVSS 6.5

silverstripe/framework Privilege Escalation Risk in Member Edit form

GHSA-xpff-c35g-j3cr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 4.1.1, 4.0.4, 3.6.6, 3.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/framework

    Affected
    >= 3.5.7-rc1, < 3.5.8>= 3.6.0-rc1, < 3.6.6>= 4.0.0-rc1, < 4.0.4>= 4.1.0-rc1, < 4.1.1
    Fixed in
    3.5.8, 4.1.1, 3.6.6, 4.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

A member with the permission EDITPERMISSIONS and access to the "Security" section is able to re-assign themselves (or another member) to ADMIN level. CMS Fields for the member are constructed using DirectGroups instead of Groups relation which results in bypassing security logic preventing privilege escalation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xpff-c35g-j3cr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xpff-c35g-j3cr

Advisory: silverstripe/framework Privilege Escalation Risk in Member Edit form
IDs: GHSA-xpff-c35g-j3cr
Record: https://patchnext.com/advisories/ghsa-xpff-c35g-j3cr (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 4.1.1, 4.0.4, 3.6.6, 3.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 3.5.7-rc1, < 3.5.8; >= 3.6.0-rc1, < 3.6.6; >= 4.0.0-rc1, < 4.0.4; >= 4.1.0-rc1, < 4.1.1; fixed in 3.5.8, 4.1.1, 3.6.6, 4.0.4

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xpff-c35g-j3cr (GitHub-reviewed advisory GHSA-xpff-c35g-j3cr lists affected ranges: Packagist silverstripe/framework >=3.5.7-rc1 =3.6.0-rc1 =4.0.0-rc1 =4.1.0-rc1 <4.1.1)

Commands are suggestions: review each one before running it.

Loading voting…