Skip to content

← Actionable
Medium, CVSS 6.9amended

marimo vulnerable to proxy abuse of /mpl/{port}/

GHSA-xjv7-6w92-42r7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (marimo 0.16.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI marimo

    Affected
    >= 0.9.20, < 0.16.4
    Fixed in
    0.16.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The /mpl/<port/<route endpoint, which is accessible without authentication on default Marimo installations allows for external attackers to reach internal services and arbitrary ports. Details From our understanding, this route is used internally to provide access to interactive matplotlib visualizations. marimo/marimo/server/main.py at main · marimo-team/marimo This endpoint functions as an unauthenticated proxy, allowing an attacker to connect to any service running on the local machine via the specified <port and <route. The existence of this proxy is visible in the application's code (marimo/server/main.py), but there's no official documentation or warning about its behavior or potential risks. Impact CWE-441: Proxying Without Authentication This vulnerability, as it can be used to bypass firewalls and access internal services that are intended to be local-only. The level of impact depends entirely on what services are running and accessible on the local machine. Full…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xjv7-6w92-42r7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xjv7-6w92-42r7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xjv7-6w92-42r7

Advisory: marimo vulnerable to proxy abuse of /mpl/{port}/
IDs: GHSA-xjv7-6w92-42r7
Record: https://patchnext.com/advisories/ghsa-xjv7-6w92-42r7 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: marimo 0.16.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI marimo: affected >= 0.9.20, < 0.16.4; fixed in 0.16.4

## Suggested inspection (read-only)
- `python -m pip show marimo`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on marimo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xjv7-6w92-42r7 (OSV record GHSA-xjv7-6w92-42r7 lists affected ranges: PyPI marimo >=0.9.20 <0.16.4 (fixed))
- Verified: https://github.com/advisories/GHSA-xjv7-6w92-42r7 (GitHub-reviewed advisory GHSA-xjv7-6w92-42r7 lists affected ranges: PyPI marimo >=0.9.20 <0.16.4)

Commands are suggestions: review each one before running it.

Loading voting…