Skip to content

← Actionable
High, CVSS 7.4

ZendFramework Potential Information Disclosure and Insufficient Entropy vulnerabilities

GHSA-xg9w-r469-m455

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework 2.1.4, 2.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

In Zend Framework 2, the Zend\Math\Rand component generates random bytes using the OpenSSL or Mcrypt extensions when available but will otherwise use PHP's mtrand() function as a fallback. All outputs from mtrand() are predictable for the same PHP process if an attacker can brute force the seed used by the Marsenne-Twister algorithm in a Seed Recovery Attack. This attack can be successfully applied with minimum effort if the attacker has access to either a random number from mtrand() or a Session ID generated without using additional entropy. This makes mtrand() unsuitable for generating non-trivial random bytes since it has Insufficient Entropy to protect against brute force attacks on the seed. The Zend\Validate\Csrf component generates CSRF tokens by SHA1 hashing a salt, random number possibly generated using mtrand() and a form name. Where the salt is known, an attacker can brute force the SHA1 hash with minimum effort to discover the random number when mtrand() is utilised as a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xg9w-r469-m455

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xg9w-r469-m455

Advisory: ZendFramework Potential Information Disclosure and Insufficient Entropy vulnerabilities
IDs: GHSA-xg9w-r469-m455
Record: https://patchnext.com/advisories/ghsa-xg9w-r469-m455 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework 2.1.4, 2.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist zendframework/zendframework: affected >= 2.0.0, < 2.0.8; >= 2.1.0, < 2.1.4; fixed in 2.0.8, 2.1.4

## Suggested inspection (read-only)
- Packagist zendframework/zendframework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zendframework/zendframework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xg9w-r469-m455 (GitHub-reviewed advisory GHSA-xg9w-r469-m455 lists affected ranges: Packagist zendframework/zendframework >=2.0.0 =2.1.0 <2.1.4)

Commands are suggestions: review each one before running it.

Loading voting…