Skip to content

← Actionable
Critical, CVSS 9.1amended

Better Auth Has Two-Factor Authentication Bypass via Premature Session Caching (session.cookieCache)

CVE-2026-67337GHSA-xg6x-h9c9-2m83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.4.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-67337: 0.46% estimated exploitation activity in the next 30 days; percentile 40.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Under certain configurations, sessions may be considered valid before two-factor authentication (2FA) is fully completed. This can allow access to authenticated routes without verifying the second factor. --- Description When two-factor authentication is enabled, the authentication flow correctly identifies users who require additional verification and defers full authentication until the second factor is completed. However, when session.cookieCache is enabled, the session generated during the initial sign-in step may be cached as valid prior to 2FA verification. Subsequent session lookups may then return this cached session without re-evaluating the 2FA requirement. This results in a situation where session validity can be established before all authentication constraints are satisfied. --- Impact An attacker (or user) with valid primary credentials may gain access to protected application routes without completing the required second authentication factor. Any application…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-xg6x-h9c9-2m83

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-xg6x-h9c9-2m83

  4. Revision 1 · created ·

    Published from ghsa record GHSA-xg6x-h9c9-2m83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-67337

Advisory: Better Auth Has Two-Factor Authentication Bypass via Premature Session Caching (session.cookieCache)
IDs: CVE-2026-67337, GHSA-xg6x-h9c9-2m83
Record: https://patchnext.com/advisories/ghsa-xg6x-h9c9-2m83 (revision 4, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.4.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected < 1.4.9; fixed in 1.4.9

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xg6x-h9c9-2m83 (GitHub-reviewed advisory GHSA-xg6x-h9c9-2m83 lists affected ranges: npm better-auth >=0 <1.4.9)
- Verified: https://osv.dev/vulnerability/GHSA-xg6x-h9c9-2m83 (OSV record GHSA-xg6x-h9c9-2m83 lists affected ranges: npm better-auth >=0 <1.4.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…