Skip to content

← Actionable
Low, CVSS 2.3amended

@eslint/plugin-kit is vulnerable to Regular Expression Denial of Service attacks through ConfigCommentParser

GHSA-xffm-g5w8-qvg7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@eslint/plugin-kit 0.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The ConfigCommentParser#parseJSONLikeConfig API is vulnerable to a Regular Expression Denial of Service (ReDoS) attack in its only argument. Details The regular expression at packages/plugin-kit/src/config-comment-parser.js:158 is vulnerable to a quadratic runtime attack because the grouped expression is not anchored. This can be solved by prepending the regular expression with [^-a-zA-Z0-9/]. PoC Impact This is a Regular Expression Denial of Service attack which may lead to blocking execution and high CPU usage.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xffm-g5w8-qvg7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xffm-g5w8-qvg7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-xffm-g5w8-qvg7

Advisory: @eslint/plugin-kit is vulnerable to Regular Expression Denial of Service attacks through ConfigCommentParser
IDs: GHSA-xffm-g5w8-qvg7
Record: https://patchnext.com/advisories/ghsa-xffm-g5w8-qvg7 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @eslint/plugin-kit 0.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @eslint/plugin-kit: affected < 0.3.4; fixed in 0.3.4

## Suggested inspection (read-only)
- `npm ls @eslint/plugin-kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @eslint/plugin-kit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xffm-g5w8-qvg7 (OSV record GHSA-xffm-g5w8-qvg7 lists affected ranges: npm @eslint/plugin-kit >=0 <0.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-xffm-g5w8-qvg7 (GitHub-reviewed advisory GHSA-xffm-g5w8-qvg7 lists affected ranges: npm @eslint/plugin-kit >=0 <0.3.4)

Commands are suggestions: review each one before running it.

Loading voting…